Classic British SparesKlempf British PartsBaxter CycleBritBike Sponsor SteadfastCyclesSRM EngineeringLucas Classic MotorcycleHepolite PistonsIndustrial tec supply

Upgrade your membership to: Premium Membership | Gold Membership | Life Membership | Vendor Membership | Site Sponsor Membership
Welcome to BritBike Forum!
Britbike forum logo
Member Spotlight
Semper Gumby
Semper Gumby
Atlanta, GA USA
Posts: 2,655
Joined: February 2007
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Search eBay for motorcycle parts in following countries
Australia, Canada, France, Holland, Italy, United Kingdom, USA
Thread Like Summary
Allan G
Total Likes: 1
Original Post (Thread Starter)
#814209 06/27/2020 6:04 PM
by Ragmanx
Ragmanx
I have a 1968 A65l with a rebuilt engine.

An SRM pump and remote oil filter were installed during the re-build.

My problem is I that the oil pressure runs to high at cruising speed.
Pressure begins to raise and begins to weep from the left side head stud.

I'll bring it to a good mechanic for a pressure check and look a look-see., but he is swamped.
Any ideas on what is causing the problem?

Thank you,
Steve
Liked Replies
#814642 Jul 1st a 05:42 AM
by Ragmanx
Ragmanx
Took it out 40 miles and no more rocker cover leak.

Planed cover on wet/dry sandpaper on plate of glass to make cover completely flat, used O-rings on center studs, used Permatex Aviation gasket sealer on both sides of a new gasket, as suggested. No more leaks!

Thanks guys!!

Steve
1 member likes this
Job CycleBritish Cycle SupplyMorries PlaceKlempf British PartsPodtronicVintage MagazineBSA Unit SinglesBritBike SponsorBritish Tools & FastenersBritBike SponsorBritBike Sponsor






© 1996-2021 britbike.com
Powered by UBB.threads™ PHP Forum Software 7.7.5