Britbike forum

Classic British Spares Klempf British PartsBaxter Cycle BritBike Sponsor SteadfastCyclesSRM Engineering Lucas Classic Motorcycle Industrial tec supply Hepolite Pistons The Bonneville ShopLowbrow Customs

Upgrade your membership to: Premium Membership | Gold Membership | Life Membership | Vendor Membership | Site Sponsor Membership
Member Spotlight
Richard Phillips
Richard Phillips
San Luis Obispo, CA
Posts: 776
Joined: August 2001
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Top Posters(30 Days)
Rohan 82
quinten 79
Top Likes Received (30 Days)
Newest Members
Edalfa, SDiff, Chopperbabe, Looping, Teager
11,844 Registered Users
Who's Online Now
4 members (Mark Parker, Andy Higham, triton thrasher, L.A.B.), 20 guests, and 64 robots.
Key: Admin, Global Mod, Mod
Previous Thread
Next Thread
Print Thread
#852525 06/27/21 7:02 pm
Joined: May 2021
Posts: 31
Z
Z900 Offline OP
Britbike forum member
OP Offline
Britbike forum member
Z
Joined: May 2021
Posts: 31
On my B33 1957/58 with a standard 4 spring clutch has the below mainnut (on the left) so with a square on it.

I've ordered 4 diff mainnuts (hexacons) but no one fits.

Any idea to find a hexacon replacement ?

[Linked Image from i.gyazo.com]

BSA on eBay
Joined: Feb 2014
Posts: 912
Likes: 138
C
Britbike forum member
Offline
Britbike forum member
C
Joined: Feb 2014
Posts: 912
Likes: 138
Hi Z
It appears that the available nuts do not have the threads fully cut, I have seen this mentioned on the A10 Forum,
I found the same issue on a new nut about 5 years ago so it appears they are still "wrong"
Luckily I have a 5/8 x 20 tap, running it through the nut cured the problem

If you cannot find a tap you could send me the nut and I can sort it (them)

John

1 member likes this: Z900
Joined: May 2021
Posts: 31
Z
Z900 Offline OP
Britbike forum member
OP Offline
Britbike forum member
Z
Joined: May 2021
Posts: 31
Hi John. the problem is not that the thread isnt fully cut, but i can only bring it up bij 1/2 turn on the shaft. So the thread isnt the right one.

Last edited by Z900; 06/28/21 3:53 pm.
Joined: Oct 2008
Posts: 1,717
Likes: 9
L
Britbike forum member
Offline
Britbike forum member
L
Joined: Oct 2008
Posts: 1,717
Likes: 9
In your pictures the thread on the new nut on the right doesn't look fully cut to me.

1 member likes this: Allan G
Joined: May 2021
Posts: 31
Z
Z900 Offline OP
Britbike forum member
OP Offline
Britbike forum member
Z
Joined: May 2021
Posts: 31
Originally Posted by LarryLebel
In your pictures the thread on the new nut on the right doesn't look fully cut to me.

Yes, that were my thoughts also....the thread seems not "sharp" enough ...isnt it ?


Moderated by  Allan G, Jon W. Whitley 

Link Copied to Clipboard
Job CycleBritish Cycle SupplyMorries PlaceKlempf British PartsPodtronicVintage MagazineBSA Unit SinglesBritBike SponsorBritish Tools & FastenersBritBike SponsorBritBike Sponsor






© 1996-2021 britbike.com
Powered by UBB.threads™ PHP Forum Software 7.7.5